support  version  Java  EDI